Libelium is offering new technical support channels, to contact with de Technical Support team to solve any issue our doubt please contact with your sales agent or visit our contact site



Post a new topicPost a reply Page 2 of 3   [ 21 posts ]
Go to page Previous  1, 2, 3  Next
Author Message
 Post subject: Re: Issues with the AT+CREG? Command
PostPosted: Sun Mar 25, 2018 5:17 pm 

Joined: Sun Feb 18, 2018 8:42 pm
Posts: 13
Hi

So having purchased an adaptor for my micro-sim card, I am confused as to how this SIM card is supposed to be inserted as it seems that the SIM card clearly would not fit in the SIM card slot of the SIM908 shield, I will post an image in the URL below to illustrate my point:
https://imgur.com/a/CnUkR

Apologies if I am missing something but it seems that the SIM card slot on the SIM908 is supposed to work alongside a microSIM card.

Thanks


Top
 Profile  
 
 Post subject: Re: Issues with the AT+CREG? Command
PostPosted: Mon Mar 26, 2018 3:13 pm 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
Hi,

You have to insert the sim card as is showed in the following image
http://www.libelium.com/forum/libelium_ ... im900.jpeg

Regards


Top
 Profile  
 
 Post subject: Re: Issues with the AT+CREG? Command
PostPosted: Fri Mar 30, 2018 5:12 pm 

Joined: Sun Feb 18, 2018 8:42 pm
Posts: 13
Thanks

That fixed the issue, it never occured to me that a SIM card needed to be entered sideways.

However it seems as one issue is resolved another one arises. The module gets stuck at the "AT+CGPSSTATUS?" command. It does not go beyond this step and when the number is called, an SMS is not sent in response.

When uploading the bareMinimum.ino, the location comes up as unknown as shown in the link below:
https://imgur.com/a/NUkEz

Any help would be appreciated?


Top
 Profile  
 
 Post subject: Re: Issues with the AT+CREG? Command
PostPosted: Mon Apr 02, 2018 3:30 pm 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
Hi,

Did you connect the GPS antenna? Could you try outside? GPS position can't be get in a indoor place.

Regards


Top
 Profile  
 
 Post subject: Re: Issues with the AT+CREG? Command
PostPosted: Fri Apr 13, 2018 1:38 pm 

Joined: Sun Feb 18, 2018 8:42 pm
Posts: 13
Hi

I will attach an image below showing my connections, my issues still persist even after trying to test this outdoors:
https://imgur.com/a/jZeRR

The connections should be correct as far as I know and according to the cooking hacks tutorial being followed which I will link below:

https://www.cooking-hacks.com/projects/arduino-realtime-gps-gprs-vehicle-tracking

Any help would be appreciated, I can't see where I am going wrong in my coding and hardware setup so any advice would be appreciated

Regards


Top
 Profile  
 
 Post subject: Re: Issues with the AT+CREG? Command
PostPosted: Mon Apr 16, 2018 12:14 pm 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
Hi,

Did you set the jumpers in the correct positions? Please share with us an image where we can see the jumpers position
https://www.cooking-hacks.com/documenta ... pi/#shield

Regards


Top
 Profile  
 
 Post subject: Re: Issues with the AT+CREG? Command
PostPosted: Tue Apr 17, 2018 12:00 am 

Joined: Sun Feb 18, 2018 8:42 pm
Posts: 13
Hi

I have followed the instructions correctly as far as I can tell, I will attach an image below of the jumper positions as well as provide more information in the description.

https://imgur.com/a/tXOT9

Just as a reminder, my issues occur at the point where the GPS antenna is trying to obtain a signal as it is unable to detect a location and as a result no SMS message is being sent from the Arduino to the mobile device.

Thanks for the help so far and hopefully someone can point out where I am going wrong

Regards


Top
 Profile  
 
 Post subject: Re: Issues with the AT+CREG? Command
PostPosted: Tue Apr 17, 2018 9:41 am 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
Hi,

It seems that the jumpers aren't in the right position. Please take a look at this image to know the correct position according your configuration.
https://www.cooking-hacks.com/media/coo ... am_big.png

Regards


Top
 Profile  
 
 Post subject: Re: Issues with the AT+CREG? Command
PostPosted: Tue Apr 17, 2018 3:30 pm 

Joined: Sun Feb 18, 2018 8:42 pm
Posts: 13
Hi

From looking at the image more carefully more carefully I can see that the two serial COM jumpers on the top are supposed to be on the right like so:

https://imgur.com/a/ERx1u

However the second jumper configuration should be correct as once the code has been uploaded, the serial COM jumpers should moved to 'Ard' on the left hand side.

Can someone please clarify if this is correct ?

Either way the outcome is still the same so I am not sure what the solution is here. If there are other potential causes for the issue of the GPS not finding the location of the Arduino could someone explain it to me ?

Thanks


Top
 Profile  
 
 Post subject: Re: Issues with the AT+CREG? Command
PostPosted: Tue Apr 17, 2018 10:40 pm 

Joined: Sun Feb 18, 2018 8:42 pm
Posts: 13
Hi

To extend on to the previous post, I have also been trying to send send SMS messages from the Arduino using the SIM908 module.

I have been doing this manually within the putty terminal (I am not sure how to send SMS via the arduino serial terminal as CTRL-Z is not recognised by Arduino's serial monitor).

I enter my AT Commands as so:
Code:
AT
OK
AT+CREG?
+CREG: 1,1

OK
AT+CMGF=1
OK

AT+CPIN="0000"
+CME ERROR: 3

AT+CMGS="******"
> This is the text message.
>
+CMS ERROR: 515



I get CME Error 3 for the +CPIN command indicating that the operation is not allowed and CMS ERROR: 515 everytime I try to send an SMS message. Apologies for all the questions and posts but I am trying to explore all the possible causes to the issues I am having.

Could someone please explain what could be causing these errors and how to fix them ?

Thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 2 of 3   [ 21 posts ]
Go to page Previous  1, 2, 3  Next


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Libelium theme based on 610nm Style by Daniel St. Jules of http://www.gamexe.net


© Libelium Comunicaciones Distribuidas S.L. | Terms of use.